Troubleshooting for Salesforce

The following information can help you troubleshoot and resolve common issues with Salesforce.

Table of Contents

How to troubleshoot common issues with Salesforce

Unable to synchronize Zoom Webinars attendees to Salesforce

Ensure that the BAA security is disabled for the user’s Zoom account. The BAA security feature blocks data sync.

Unable to install the app

Using probabilistic encryption on fields used by the Zoom integration blocks the app installation. To enable successful app installation, ensure that you use only deterministic encryption for the contact and lead fields.

Developer Script Error: XXX: unknown: Inactive User, orgID: XXX

  1. Open the Scheduled Jobs page.
  2. Delete the ZoomMettingMetrics Schedule job.
  3. Open the Zoom Config page and edit the page.
  4. Click Save to resubmit the job.

Meeting ID shows as null

Log in to Salesforce and confirm that Remote Site Settings is active for the Zoom app.

Unable to receive Zoom invitations emails sent from Salesforce

Check your Email Deliverability settings; set them to All Mail.

Error: Your email is not a valid Zoom User

Confirm that the Salesforce user email matches the Zoom account email.

The Start a Meeting button in Salesforce is not working

Your Salesforce administrator may have assigned 2 record types to your user.

  1. Open Object Settings then click Events.
  2. Set one of them as the Default Record Type.

I am unable to create a Zoom Meeting or Zoom Webinars from Salesforce

  1. Sign in to the Zoom web portal as an admin.
  2. In the navigation menu, click Account Management then Account Settings.
  3. Click the Meeting tab.
  4. Under Security, find Password Requirement and view your selected check boxes.
  5. Ensure that the meeting password you set in Salesforce conforms to the Password Requirement set in your Zoom account.

Unable to initiate a direct Zoom call from Salesforce

Salesforce requires the Zoom desktop client, version 5.2 or higher (for Windows and macOS). Ensure that you are using the latest version of the Zoom desktop client.

Add to Webinar (List button) does not work as expected

In the list view on a contacts or leads page, clicking Add to Webinar results in a page error. This error occurs when the contact or lead name is encrypted and makes the column unsortable.

As a workaround, you can add a sortable first column for contacts and leads, such as the last modified date.

For more information, see this article.

Click to dial is disabled when using the Zoom Phone integration in Salesforce

Make sure the CTI adapter URL didn't change. Review the how to enable Click to dial process.

Why is the recording URL not added to the Zoom call log

For auto-recording of user-to-user calls, make sure the user is added to the Access Member List

  1. Sign in to the Zoom web portal as an admin.
  2. In the navigation menu, click Phone System Management, then Users & Rooms.
  3. Select the user and click the Policy tab.
  4. Under Automatic Call Recording, click Access Member List.
  5. Under the User tab, click Add user.
  6. Under Add access member, search for the name or extension you want to add.
  7. (Optional) Under Permission, select whether you want to provide Access, Download, or Delete permission.
  8. Click Save.

For auto-recording of the Call Queues (CQ) calls, make sure the user is added to the Access Member List.

  1. Sign in to the Zoom web portal as an admin.
  2. In the navigation menu, click Phone System Management, then Call Queues.
  3. Select the name, then click the Policy tab.
  4. Under Automatic Call Recording, click Access Member List.
  5. Under the User tab, click Add user.
  6. Under Add access member, search for the name or extension you want to add.
  7. (Optional) Under Permission, select whether you want to provide Access, Download, or Delete permission.
  8. Click Save.

Set Shared Access Permission to Authorized in the Zoom App Marketplace.

  1. Sign in to the Zoom web portal as an admin.
  2. In the Navigation menu, click Advanced, then App Marketplace.
  3. In the upper right corner, click Manage.
  4. Under Personal app management, click Added apps.
  5. Under the Apps in Production tab, search for the Zoom for Salesforce Lightning app.
  6. Set the Shared Access Permissions to Authorized.

OAuth Error: OAUTH_APPROVAL_ERROR_GENERIC (An unexpected error has occurred during authentication. Please try again.)

Issue

Users may encounter authorization failures when attempting to connect to Salesforce.

Cause

This issue is due to a new Salesforce limitation for connected apps introduced in September 2025.
For more details, see Salesforce documentation.

The issue occurs when:

Resolution

To resolve this issue, Salesforce admins can take one of the following actions:

  1. Install the connected app in the org.

     

  2. Grant the appropriate permission to new users who need to authorize Salesforce: