Issues assigning Zoom Phone numbers to users
Issue
You need to assign phone numbers to users in your Zoom Phone system, but are unable to do one of the following:
- Assigning a new phone number to a user who doesn't have one.
- Reassigning an existing phone number from one user to another.
- Moving a phone number from an auto receptionist or other service to a user.
- Managing phone number assignments after purchasing additional licenses.
Environment
- Zoom web portal for Zoom Phone service
- Pro or Business account
Cause
Phone number assignment issues occur due to one or more of the following:
- Account members do not have a Zoom Phone license when attempting to assign them phone numbers.
- Phone numbers are not unbound from their current users or services before reassigning to different users or services when trying to reassign existing phone numbers.
Resolution
Assign phone numbers to users or services
Step 1: Assign a Zoom Phone license to your new user or service
Before assigning phone numbers to a user or service for the first time, you must assign a Zoom Phone license. Only the account owner or an admin can assign Zoom Phone licenses.
- Sign in to the Zoom web portal as an admin.
- In the navigation menu, click Phone System Management, then click Users & Rooms.
- Click the Users or the appropriate service tab.
- In the top-left corner, click Add.
- Select the user or service and package, then click Save.
Once the Zoom Phone license is assigned, you can follow the steps below to assign phone numbers.
Step 2: Acquire phone numbers from self-service
If you’re not porting your own phone numbers into Zoom, you can obtain new phone numbers directly from the Zoom web portal before assigning them to users. Only the account owner or an admin can acquire Zoom Phone numbers.
- Sign in to the Zoom web portal as an admin.
- In the navigation menu, click Number Management, then click Phone Numbers.
- Click Add Number, then Get Number.
- Select the Product, Country/Region, Type & Capability, State/Province/Territory, and Area Code - City.
- Click Search, then select your desired numbers from the list.
- Click Done.
Learn more about obtaining phone numbers.
Step 3: Assign a phone number to your user or service
After assigning a Zoom Phone license and acquiring phone numbers, you can assign a phone number to a user or service. Only the account owner or an admin can perform this action.
- Sign in to the Zoom web portal as an admin.
- In the navigation menu, click Number Management.
- Click Phone Numbers.
- On the far right of a phone number, click the more icon, then click Assign.
- Select User or the appropriate service, search their name or extension, then click Save.
For more information on assigning phone numbers, refer to the Number management for managing phone numbers article.
Reassign an existing phone number to a different user or service
If a phone number is already assigned but is no longer needed by a user or service, you can reassign it to another user or service, such as an auto receptionist. Only the account owner or an admin can make this change.
- Make sure the new user has accepted the Zoom account invitation sent to their email.
- Make sure the user has been assigned a Zoom Phone license as mentioned in the Step 1 section {link to section}.
- Sign in to the Zoom web portal as an admin.
- In the navigation menu, click Number Management, then click Phone Numbers.
- Click the specific phone number you want to reassign.
- Scroll down to Product Info.
- To the right of Assigned To, click Unbind, then click Unbind to confirm and remove the phone number from the current user or service.
The phone number will be available for reassignment. - To the right of Assigned To, click Edit.
- Select the User or service, search by name or extension, then click Save.
The phone number will be assigned to a new user or service.