Zoom Phoneの発信者番号通知とルーティングの問題
発信者番号通知の制限
- これは標準のE.164フォーマットであるため、日本の番号の国番号プレフィックス+81はZoom Phoneの設定で変更できません。受信者の端末、通信事業者、電話機の設定により、表示動作が異なる場合があります。
- 発信者番号通知ドロップダウンメニューの最大表示件数は100件です。
問題
Zoom Phoneで発信者番号通知や通話ルーティングの設定に問題が発生し、発信者情報が受信者に表示されたり、通話が転送または転送されたりする場合があります。一般的な症状は以下の通りです:
- 電話が外線番号に転送された際、元の発信者番号が表示されず、代わりに転送先の番号が表示されます。
- 発信者番号通知が、現地の番号形式ではなく、国際的な国番号のプレフィックスで表示されます。
- 自動受付の発信者番号通知設定により、断続的に通話に失敗することがあります。
- ユーザーが複数のコールキューに割り当てられている場合に、発信者番号通知ドロップダウンリストで利用可能なすべての電話番号が表示されないことがありました。
- ユーザーが、自分がメンバーではないコールキューから発信者番号通知を選択できない問題。
- 別々の企業テナント間の通話転送で、元の発信者情報が表示されません。
環境
- 転送、転送、発信者番号通知設定機能を備えたZoom Phoneサービス。
- 外線番号ルーティングによる自動受付およびIVRシステム。
- 複数の電話番号を割り当てたコールキュー。
- 組織間の通話転送が可能なマルチエクステンションZoom Phoneの導入。
- 発信者番号管理を必要とするサードパーティシステムとの統合。
原因
Zoom Phoneの発信者番号表示やルーティングの問題は、いくつかの要因によって発生する可能性があります:
- Zoom Phoneは、発信者番号表示にE.164国際フォーマットを使用しています。このフォーマットにはデフォルトで国コードが含まれており、無効にすることはできません。
- 外線番号への通話転送では、元の発信者番号ではなく、転送元の番号が表示されます。
- 発信者番号通知の設定には、ウェブポータルでの明示的な設定が必要です。
- 発信者番号通知は、ユーザーのアカウント、会社のメイン番号、またはユーザーが所属するコールキューに割り当てられた番号に制限されます。
決議
以下のソリューションを使用して、特定のシナリオに基づく発信者番号表示およびコールルーティング設定の問題を解決してください。
通話の失敗を防ぐ自動着信者IDの設定
アカウント所有者または管理者として、ユーザーの発信者IDが自動受付に設定されているために通話が失敗していると判断した場合は、以下の手順に従って、正しく設定されていることを確認するか、別の発信者IDに変更してください。
- Zoom Webポータルにサインインします。
- ナビゲーションメニューで、[電話システム管理] をクリックし、[ユーザー& 部屋] をクリックします。
- ユーザー」タブをクリックします。
- 自動受付番号を使って発信する必要があるユーザーの名前をクリックします。
- プロフィールタブをクリックします。
- 発信者番号通知]で、適切な番号(自動受付番号など)を選択します。
- 保存をクリックします。
- 設定された番号を確認するために、発信コールをテストします。
注:ユーザーに少なくとも1つの有効な発信者番号が割り当てられており、ポリシーで許可されていることを確認してください。それでも通話に失敗する場合は、 Zoom Phoneのエラーコードと 迷惑メール対策ガイダンスを確認し、ユーザーの通話プラン/ポリシーを確認し、ネットワーク/ファイアウォールの設定を確認してください。
コール・キュー・メンバーの発信者番号選択管理
ユーザーが発信者IDとしてコールキュー番号を選択できない場合、アカウントの所有者または管理者は、そのコールキューにメンバーとして追加することができます。一旦追加されると、ユーザーは発信を行い、コールキューの番号を表示することができます。以下のいずれかの手順に従って、ユーザーをコールキューに追加してください。
コールキューのメンバーとしてユーザーを追加
- Zoom Webポータルにサインインします。
- ナビゲーションメニューで、[電話システム管理]、[ コールキュー]の順にクリックします。
- 編集したいコールキュー名をクリックします。
- プロフィールタブをクリックします。
- Members(s)」の右側にある「View(表示)」または「Edit(編集)」をクリックし、以下のいずれかを実行します:
- Search for members(メンバーの検索)ボックスに、ユーザー名を入力して、そのユーザーがコールキューのメンバーであることを確認します。
- 追加をクリックします。
- ユーザーがコールキューのメンバーでない場合は、[ユーザー]タブをクリックしてユーザーを追加します。
- OKをクリックします。
電話ユーザーのプロファイルにコールキュー番号を追加
- Zoom Webポータルにサインインします。
- ナビゲーションメニューで、[電話システム管理]、[ユーザー& 部屋] の順にクリックします。
- ユーザー」タブをクリックします。
- 電話のユーザー名をクリックします。
- プロフィールタブをクリックします。
- Outbound Caller IDの右側にある、適切なコールキューの電話番号を選択します。
- 保存をクリックします。
- (オプション) [番号のカスタマイズ]で、[追加] をクリックして、ユーザーの発信者IDとしてさらに電話番号を追加します。
- Zoom Phone]タブで、コールキューの電話番号を選択します。
- 保存をクリックします。
注:ユーザーは、自分のアカウントに割り当てられた番号、会社のメイン番号、または自分がメンバーであるコールキューからのみ発信者番号を選択できます。